Unable to connect to private Instance if ACL is on

Discussion in 'Cloud Computing' started by arun_4698, Aug 10, 2017.

  1. arun_4698

    arun_4698 Member

    Joined:
    Jun 16, 2017
    Messages:
    6
    Likes Received:
    0
    I have created one VPC with public and private subnets. in addition , NAT instance is created to provide outbound internet traffic for private instance. The Public linux instance is able to connect to internet. However , if i associate the private instance to Network ACL , unable to conenct through public instance.

    If i de-associate the private instance from Network ACL , the private instance is able to connect to internet through the set NAT instance.

    My network ACL does not have any rules set other than default allow/deny rules(Enclosed screenshot)

    Could you help me to understand why the ACL 's are blocking the connectivity to Private instance and why ?

    Thanks in advance.
     

    Attached Files:

    #1
  2. Akansha Chaurasia

    Akansha Chaurasia Well-Known Member
    Simplilearn Support

    Joined:
    Jun 2, 2017
    Messages:
    75
    Likes Received:
    2
    Turn off Windows Firewall
     
    #2
  3. arun_4698

    arun_4698 Member

    Joined:
    Jun 16, 2017
    Messages:
    6
    Likes Received:
    0
    These are linux instances...both NAT as well as EC2 . Does the firewall applicable ?
     
    #3
  4. Akansha Chaurasia

    Akansha Chaurasia Well-Known Member
    Simplilearn Support

    Joined:
    Jun 2, 2017
    Messages:
    75
    Likes Received:
    2
  5. arun_4698

    arun_4698 Member

    Joined:
    Jun 16, 2017
    Messages:
    6
    Likes Received:
    0
    i am connected to the instances from my mac machine..Sorry still did not get how firewall will be applicable..

    My instances in AWS are Linux
    Connected from MAC command line

    Thanks in advance
     
    #5
  6. Akansha Chaurasia

    Akansha Chaurasia Well-Known Member
    Simplilearn Support

    Joined:
    Jun 2, 2017
    Messages:
    75
    Likes Received:
    2
    • Go to the Instances section
    • Then click on the security group associated with your EC2 instance.
    • Down the bottom click on the inbound tab and then click edit.
      - Create this rule
    • TYPE SSH
    • PROTOCOL TCP
    • PORT RANGE 22
    • SOURCE Anywhere
    • If you have a firewall on your computer, verify that it allows inbound and outbound traffic from your computer on port 22 (for Linux instances) or port 3389 (for Windows instances). Hope these steps will be helpful!
     
    #6

Share This Page